The other day I wrote an article about the upcoming release of WordPress 3.6 beta, which I’m pretty excited about. Among the various topics covered was the release of Twenty Thirteen.
Well today I’d like to dive deeper into that release and ask some questions about the philosophy of not allowing backwards compatibility.
On March 19th a Twenty Thirteen update was posted to the make.wordpress blog, saying:
Tracked in #23819 — since Twenty Thirteen is 3.6+ only, older installs could see errors. We’d like to come up with a graceful way to not allow older versions of WordPress to install and run Twenty Thirteen.
Maybe a nag function in the theme that puts up a warning? Forcing a change [to] the previously activated theme upon activation? What are your thoughts?
Here is what #23819 says concerning the backwards compatibility of Twenty Thirteen:
Twenty Thirteen is meant to be not backwards compatible. Since we incorporate a lot of new functions and rely on markup changes that are introduced in 3.6, it really doesn’t make sense to fail gracefully in a “slimmed down” version of the theme.
While we probably get some code in place on the .org side to prevent Twenty Thirteen from being downloaded through the WordPress admin, nothing prevents people from downloading it from the theme repository and upload it to their site through the zip installer.
We should be prepared to handle that in a better way than just failing with fatal errors.
With the number people working on getting Twenty Thirteen ready for release, I don’t see it failing, but I do wonder a bit about the thought process behind not making it backwards compatible.
I categorically disagree that offering a slimmed down version of Twenty Thirteen is “failing gracefully”. I see nothing wrong with making a slimmed down version for 3.5 or 3.4, if people choose to still use those versions. The point of any upgrade to a product is that the new version should be undeniably better.
If 3.6 and/or Twenty Thirteen isn’t compelling enough to cause everyone to upgrade, that falls on WordPress, not the people who choose not to upgrade. Why prevent the people access to the new theme simply because they choose not to upgrade?
And if 3.6 really is that big of a change, so as to cause a lack of backwards compatibility, why 3.6 and not 4.0? Wouldn’t such a distinction more effectively communicate the nature of the changes made? I realize this may be an over-exaggeration, but hopefully you see my point: such jumps in compatibility shouldn’t be made in the middle of a product run. Why do this now? Why not wait until 4.0 to make these compatibility changes?
I know the people that make WordPress as awesome as it is work unbelievably hard. But I would like to see them admit the truth, that it’s simply easier not to offer a slimmed down version of Twenty Thirteen, instead of saying that such an offering would be “failing gracefully”.
After saying all of this I feel like I need to restate that I am excited for 3.6 and I think Twenty Thirteen has potential to be a pretty cool theme. I’m not down on either of them, I just think the backwards compatibility issue could and should be handeld better.
I think this and the lack of editorial flow in 3.6 are prime examples of time dictating a release and not content. I’d have no problem waiting longer for 3.6 if it included these two features. In fact I’d be happy to wait longer.
Join the conversation